# Falha ao obter o token de acesso

## Problema

Quando você está tentando iniciar sessão no KONNEKT, recebe a mensagem de erro "Falha ao obter o token de acesso".

## Causa

O KONNEKT não oferece suporte a ter "Aplicativos Excluídos" em uma política de Conditional Access do Microsoft Entra (Azure AD) que exija MFA em combinação com uma sessão do Windows sem SSO.

## Solução alternativa

Nossa solução alternativa recomendada é habilitar a máquina Windows para manter um Primary Refresh Token (PRT), por exemplo, por meio de Entra Join (AAD Join) ou Register. Consulte [aqui ](https://learn.microsoft.com/en-us/entra/identity/devices/concept-primary-refresh-token#how-is-a-prt-issued)para detalhes.

Outras alternativas são (não realmente recomendadas):

* Remover a exigência de MFA da correspondente política de Conditional Access. Para manter alguma segurança para políticas de CA sem MFA, você poderia impor [Locais Confiáveis (por exemplo, os endereços IP públicos dos seus hosts VDI)](https://learn.microsoft.com/en-us/entra/identity/conditional-access/location-condition)

ou

* usar uma política de Conditional Access sem "Aplicativos Excluídos". Consulte também [configuração de Conditional Access](https://docs.konnekt.io/pt/installation/security/conditional-access).

## Solução

Foi implementada uma solução na versão 2.10 do KONNEKT - "[OAuth aprimorado](https://docs.konnekt.io/pt/configuration/system-settings/autenticacao-melhorada)".&#x20;
